分类 "经验累积" 下的文章

docker search nginx 

docker pull nginx 

--最简单启动 

 docker run  --name nginx -p 80:80 -d nginx 

#取得ID 
 docker ps | grep nginx 
#进docker 看具体路径 (可以不做) 
 docker exec -it nginx /bin/bash

阅读全文

docker-compose.yml

version: "3"
networks:
  mbsnet:
    external: true

services:
  mysql:
      restart: always
      image: mysql
      hostname: mysql
      container_name: mysql
      privileged: true
      ports:
        - 3306:3306
      #  - 80:80
      volumes:     
        - /etc/localtime:/etc/localtime:ro
        - /data-compose/mysql/conf:/etc/mysql
        - /data-compose/mysql/logs:/var/log/mysql
        - /data-compose/mysql/dbdata/mysql/:/var/lib/mysql
        - /data-compose/mysql/dbdata/mysql-files:/var/lib/mysql-files
      environment:
        MYSQL_ROOT_PASSWORD: 12345678
      #command: --default-authentication-plugin=mysql_native_password
      command: --lower_case_table_names=1
      networks:
        mbsnet:
            ipv4_address: 172.10.0.10

my.cnf [/data-compose/mysql/conf]

# Copyright (c) 2017, Oracle and/or its affiliates. All rights reserved.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; version 2 of the License.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301 USA

#
# The MySQL  Server configuration file.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

[mysqld]
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
datadir         = /var/lib/mysql
secure-file-priv= NULL

# Custom config should go here
!includedir /etc/mysql/conf.d/
max_connections=1000
wait_timeout=120
interactive_timeout=300
lower_case_table_names=1

阅读全文

1 编辑

vi /etc/config/firewall
config zone
        option name 'wan'
        option network 'wan'
        option input ‘ACCEPT’ (修改)


<!--more-->

增加

config rule
        option name 'Open  Samba on WAN'
        option src 'wan'
        option proto 'tcp udp'
        option dest_port '137 139 445'
        option target 'ACCEPT'

config redirect
        option name 'wan samba'
        option src 'wan'
        option src_dport '137 139 445'
        option dest 'lan'
        option proto 'tcp udp'

2 编辑

vi /etc/samba/smb.conf.template
        interfaces = br-lan wan  #此行修改
        #bind interfaces only = yes   #此行注释掉

接着重启一下即可!

阅读全文